Tuesday, February 25, 2014

MintBox 2 - The Ongoing Saga

Back at the end of November I purchased a MintBox 2, referred to below as the unit, from Amazon.  Sadly, my primary desktop PC had just passed away, and due to being swamped with various other matters, I needed a new PC fast and painlessly.  Amazon is definitely fast, even without drones.

The MinBox (the unit) seemed to be a good solution.  The box features Mint 15 Linux, pre-installed, and has loads of ports, a good sized hard drive, and quiet and low power operation.  It seems to be a outstanding value!

I am used to Ubuntu, but I did like the way Mint worked right out of the box.  It also worked fine with my printer and a USB camera without the slightest hassle.

There were a few issues...

The screen lock always came on after 2 or 3 minutes, no matter what you changed the screen lock/saver settings to (Really??  it's 2014 and we have bugs like that?  Really?).

Also, 2 or 3 times, the machine either rebooted itself overnight, or froze up and had to be hard powered off, and restarted.

Then is February, I went to use the PC for some PC stuff, and was greeted by a Grub loader menu.

The keyboard was unresponsive.  Num Lock did not even turn on the Num Lock LED.  It was hung completely...

I powered down, and back on.  Same thing.  It would go no further than a Grub menu (which I had never seen before on the unit), and it was locked up tight.

A few things I did...

I booted from a USB stick with a Ubuntu image.  I worked fine.  The MintBox's hard drive was there, all my files were there.  It ran fine, when boot from USB.  Everything worked.

I had not had the unit long enough to have really setup everything I wanted so there wasn't much to worry about.  After getting a couple of files off there, I installed Ubuntu from the USB device.  The install went fine.

On boot though, same thing - frozen grub screen...

So I Ubuntu'ed it again, this time I made sure to change the patricians so the disk would get formatted.  Same thing happened...  So next I installed Mint Linux 15, from a USB device.  Same thing.  Grub menu, dead keyboard...

Someplace along the way, I contacted MintBox support.  They suggested re-seating the hard drive and the memory cards.  I wasn't thrilled about having to open the unit up, and I didn't expect a change, but I did it anything.  And as expected, nothing changed.  Support also suggested trying a different hard drive, but I didn't have one of the correct type.  I really don't think it would have made a difference, the drive was fine when boot was from a USB device.

Support also pointed out the two of the unit's USB ports are USB3 and I need to use USB2 for the keyboard.  This didn't help, I had been using the USB ports on the front all along.  The USB3 ports are on the back of the unit, and are blue.partitions

Support also noticed, on my screen images, that EFI partitions seems to have been created.  They wanted me to get into the BIOS settings (F2 at post) and disable EFI.

Funny thing though, the keyboard, during post, is unresponsive.  Pressing F2 does nothing.  Pressing Num Lock does nothing.  Only after an O/S starts, from a USB device, is the keyboard alive.  There appears to be no way to get the the BIOS settings!

The unit will be on it's way back for service shortly.